Incoming Email Issues
Incident Report for Cloud Next
Resolved
Our system administrators have now resolved the issues with incoming email.
Posted Jan 28, 2024 - 19:02 UTC
Investigating
We're receiving reports of issues in relation to receiving email. Our System Administrators are currently investigating and updates will be provided as we have more information available.
Posted Jan 28, 2024 - 18:20 UTC
This incident affected: Email & Webmail.